Error connecting to DB2

Support information related to IBM DB2 Databases

Error connecting to DB2

Postby samuel » Mon Sep 20, 2010 12:03 am


I'm getting errors trying to create a new connection to DB2 local databases.
I have tried both OLEDB and ODBC connections from DynamicAI interface but no success.

This is my environment:
Windows 7 Ultimate , 32 bits, English
DB2 9.7 Express-C FP 2
DynamicAI 6.4 Personal Edition

My user id is in Administrator Group, and it has full SYSADM authority in DB2.

I'm able to connect to this database using ODBC and also other applications like VDF and Java.

1. Using OLEDB :
At the first test connection attempt, I get no errors, only a "Processing..." message.
The seccond time I click the "Test connection" button I receive a the following error: "Provider cannot be found. It may not be properly installed." Please, see picture attached (OLEDB_2).
By the third time I click the "Test Connection" button, then I receive "Unspecified error".

2. Using ODBC connection:
I have created and successfuly tested an ODBC connection to my DB2 local database. No error in ODBC Layer. (Look the second picture attached, ODBC_Test).
This time I get the error: "[IBM][CLI Driver] SQL1092N "IUSR" does not have the authority to perform the requested command or operation. "
Please see attachement ODBC_Error.

I have granted IUSR user the most privilege I can, what else is needed.. and why Dynamic is using IUSR (iis user) to conncet to database instead of the user I have supplied in the connection window... ?

Please, what am I missing here ?
I would like to use OLEDB instead of ODBC, but now none is working here...
DynamicAI_64_DB2_ODBC_Error.png (12.67 KiB) Viewed 64210 times
DynamicAI_64_DB2_ODBC_Test.png (40.15 KiB) Viewed 64210 times
DynamicAI_64_DB2_OLEDB_2.png (13.69 KiB) Viewed 64210 times
Samuel Pizarro
Estância Árvore da Vida
Posts: 15
Joined: Mon Jun 16, 2008 3:21 pm
Location: Brazil

Re: Error connecting to DB2

Postby Carsten Sørensen » Mon Sep 27, 2010 9:42 am

Hi Samuel,

Were you able to resolve this in the meantime? I'm pretty sure it is a machinename_IUSR rights issue related to the DB2 drivers / OLEDB/ODBC...

To answer your question regarding why Dynamic AI is using the IUSR instead of the database user... - Dynamic AI use the IUSR rights to initiate the connection to the database and use the DB user/assigned DB user-rights to connect to the database. IUSR is the the web-service user and DB user is the database user. In principle we could have a IUSR account in all databases or you could have all needed DB users added as web-service user accounts. In either case you would have to do some additional user rights maintenance. With the current IUSR / DB user rights distribution you - in most cases - don't have to do anything specific for Dynamic AI to function as the IUSR is setup to give you all needed web-services access and whatever existing DB user that you connect with will work underneath that context.

Best regards,
User avatar
Carsten Sørensen
Certified Dynamic AI Professional
Posts: 304
Joined: Thu Aug 16, 2007 1:25 pm
Location: Copenhagen

Re: Error connecting to DB2

Postby samuel » Tue Sep 28, 2010 1:21 am

Hi Carsten.

Yes, I was able to fix that. Sorry for taking so long to answer.

I have granted IUSR user connect privilege to database.
But I don't know somehow, It was not working anyway in the same momment I have installed DAI.

It only worked properly, for both errors (ODBC and OLEDB), after I rebooted my machine.

Thanks very much!
Samuel Pizarro
Estância Árvore da Vida
Posts: 15
Joined: Mon Jun 16, 2008 3:21 pm
Location: Brazil

Return to IBM DB2